Import des journaux d'EPICEA Legrain vers Ekylibre

A l'export des journaux EPICEA fournit un fichier nommé, par exemple, Journaux_2016.txt Ce fichier est de type CSV: le séparateur de champ est le ; Pour pouvoir le voir correctement dans un tableur il faut le renommer en Journaux_2016.csv

Voici, ci dessous dans votre éditeur de texte préféré, un extrait d'export des journaux réalisés avec EPICEA avant de l'avoir renommé:

Examinons ce fichier: L'export d'EPICEA

  1. présente le numéro d'opération après la Date; Ekylibre attend l'inverse
  2. ne répète pas le Numéro d'opération sur toutes les lignes; Ekylibre attend le numéro d'opération sur chaque ligne
  3. pour les valeurs décimales, l'export d'EPICEA utilise la virgule; Ekylibre attend le point

Bref, il va falloir bricoler dans le tableur pour mettre tout cela importable correctement par Ekylibre

Ci dessous l'extrait du fichier ci dessus renommé

Après avoir inséré une colonne agauche du champ compte, puis copié la colonne Date à droite de la colonne Référence, puis supprimé la colonne Référence en colonne B nous obtenons:

Puis on insère une colonne entre la colonne B et C

Dans la colonne vide obtenue, colonne C, on écrit en cellule C2 la formule =SI(B2<>“”;B2;C1)

Voir ci dessous:

Ensuite on sélectionne toute les valeurs de la colonne C et l'on fait “Copier” On positionne le curseur en position B2 et on fait Copier Valeurs (on ne copie pas les formules) On peur alors supprimer la colonne C. Ensuite on sélectionne la colonne les connes G et H et on fait Rechercher/Remplacer la virgule par le point.

On obtient alors le tableau prêt à l'import dans Ekylibre:

Rendez vous dans Ekylibre menu Outils → Import → Nouveau On choisit le Type Journeaux EPICEA Legrain On selectionne le fichier obtenu ci dessus On clique sur crér Puis on clique sur Importer. On attend un peu et au bout d'un moment la cloche en haut à droite de l'écran doit “rougir” et indiquer commenl l'import s'est passé.

Si tout va bien, en allant dans Comptabilité → Journaux on doit constater que des journaux ont été crées automatiquement et nommés “Journal ACH” par exemple dans notre cas ou “journal XYZ” dans le cas général

Attention

  • Il faut que les dates soient de la forme JJ/MM/AAAA dans le fichier csv à importer (et non de la forme JJ/MM/AA)
  • Le temps mis pour importer peut être important (pour 8500 lignes, cela a mis plusieurs heures), ne pas trop s'impatienter.